Let It Be…


准备升级 WordPress 2.0

Posted in WordPress by calon on January 12, 2006

因为安装 Ultimate Tag Warrior 的时候受了打击,所以下定决心把“滞销书”一次升级WordPress 2.0 版本,如果这几天 blog 无法访问,说明正在升级,或者升级失败,或者恢复失败… Orz
另外 RSS Feed 也可能出现异常状况。

先在 blog 上记录一下步骤,到时候也好知道到底是怎么死的。

1、备份数据库。
使用 Database Backup 插件导出数据库表。没有用 PhpMyAdmin,因为我是个懒人。到时候出了问题再搬救兵好了。按照常理,像我这样经常很倒霉的人出问题的概率是相当大的,何况还要偷懒…

2、备份文件。
虽然一些 blogger 说 wp-content 目录中的内容可以不备份,但我修改过默认模板的文件,所以要备份一下,升级后再看具体情况作修改。

3、停用所有的插件。
目前使用的插件有 AdhesiveAnother Random QuoteFancyTooltipsSearchNowTwilight AutoSaveUltimate Tag Warriorwp-DefineWordPress Database BackupBetter Feed

4、下载 WordPress 2.0 文件。
下载地址

5、删除文件。
保留的目录、文件:wp-config.php、wp-content 目录、wp-images 目录,必要的话,保留 wp-includes/languages/ 目录、.htaccess 文件,以及其他一些自己修改过的文件。
删除剩下的 WordPress 1.5.x 的文件。

6、上传 WordPress 2.0 文件。
最后上传 wp-content 目录,覆盖的时候要小心谨慎。

7、执行 wp-admin/upgrade.php。
然后就看人品是否过硬了。

8、在 Options 面板中重新设置 Permalinks

9、更新、激活插件。
更新 Ultimate Tag WarriorBetter FeedSearchNow,试用 Random QuoteThemeSwitcher

Advertisements

5 Responses to '准备升级 WordPress 2.0'

Subscribe to comments with RSS or TrackBack to '准备升级 WordPress 2.0'.

  1. hhalloyy said,

    我觉得不用禁用插件啊。

  2. hhalloyy said,

    我觉得不用禁用插件啊。

  3. Calon said,

    安全第一,安全第一 😀

  4. Calon said,

    安全第一,安全第一 😀


  5. […] å‡çº§æ­¥éª¤å‚è€ƒä»¥å‰çš„æ–‡ç« ä¿®æ”¹è€Œæˆï¼š […]


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s


%d bloggers like this: